<!DOCTYPE html>
<!--[if lt IE 7]> <html  xmlns="http://www.w3.org/1999/xhtml" prefix="" lang="en-US" xmlns:og="http://ogp.me/ns#" xmlns:fb="http://ogp.me/ns/fb#" class="no-js ie6"> <![endif]-->
<!--[if IE 7]>    <html  xmlns="http://www.w3.org/1999/xhtml" prefix="" lang="en-US" xmlns:og="http://ogp.me/ns#" xmlns:fb="http://ogp.me/ns/fb#" class="no-js ie7"> <![endif]-->
<!--[if IE 8]>    <html  xmlns="http://www.w3.org/1999/xhtml" prefix="" lang="en-US" xmlns:og="http://ogp.me/ns#" xmlns:fb="http://ogp.me/ns/fb#" class="no-js ie8"> <![endif]-->
<!--[if IE 9]>    <html  xmlns="http://www.w3.org/1999/xhtml" prefix="" lang="en-US" xmlns:og="http://ogp.me/ns#" xmlns:fb="http://ogp.me/ns/fb#" class="no-js ie9"> <![endif]-->
<!--[if (gt IE 9)|!(IE)]><!--> <html  xmlns="http://www.w3.org/1999/xhtml" prefix="" lang="en-US" xmlns:og="http://ogp.me/ns#" xmlns:fb="http://ogp.me/ns/fb#" class="no-js"> <!--<![endif]-->
<head>
	<meta charset="UTF-8" />
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
	<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0">
	<title>
		Haverhill Marina President Reports Trailer Broke Loose, Causing Employee’s Facial Injury | WHAV	</title>
	<link rel="profile" href="https://gmpg.org/xfn/11" />
	<link rel="pingback" href="https://whav.net/xmlrpc.php" />

<!-- BEGIN Metadata added by the Add-Meta-Tags WordPress plugin -->
<meta name="robots" content="noodp,noydir" />
<meta content="Public Media of New England, Inc. ©2014" name="copyright" />
<meta content="worldwide" name="distribution" />
<meta content="document" name="resource-type" />
<meta content="General" name="rating" />
<meta content="3 days" name="revisit-after" />
<meta content="ALL" name="ROBOTS" />
<meta content="100% Locally Owned Radio Stations" name="DC.Title" />
<meta content="COCO+CO." name="DC.Creator" />
<meta content="100% Locally Owned Radio Stations" name="DC.Subject" />
<meta content="100% Locally Owned Radio Stations" name="DC.Description" />
<meta content="COCO+CO." name="DC.Publisher" />
<meta content="radio,Internet radio,broadcast,broadcasting,community,Haverhill,Massachusetts,Shoutcast,advertising,audio,multimedia,iTunes,winamp,realplayer,real audio,world wide web,www,drama,music,news,weather,Top 40,local,regional,national,worldwide,Boston,Suffolk,Essex,listen,hear,voice,FCC,North Shore,Merrimack Valley,Haverhill,Groveland,Andover,Methuen,Lawrence,Lowell,Plaistow,Sandown" name="DC.Contributors" />
<meta scheme="RFC1766" content="EN" name="DC.Language" />
<meta content="Haverhill, MA, USA" name="DC.Coverage.PlaceName" />
<meta name="description" content="The president of a Haverhill marina, where a man received “severe” facial injuries Saturday morning, said he and his staff are “all shocked and saddened by the accident." />
<meta name="keywords" content="whav, whav, whav.net, whav.net, radio, internet radio, lpfm, broadcast, broadcasting, community, haverhill,massachusetts, shoutcast, advertising, audio, multimedia, itunes, winamp, realplayer, real audio, drama, music, news, weather, top 40, local, regional, national, worldwide, boston, suffolk, essex, rockingham, listen, hear, voice,f cc, north shore, merrimack valley, haverhill, groveland, andover, methuen, lawrence, lowell, plaistow, sandown, public, haverhill, homepage featured, homepage top story" />
<!-- END Metadata added by the Add-Meta-Tags WordPress plugin -->

<title>Haverhill Marina President Reports Trailer Broke Loose, Causing Employee’s Facial Injury &#8211; WHAV</title>
		<script>
			function whichHeader() {
				var screenWidth = document.documentElement.clientWidth,
				header_img;
				if (screenWidth <= 767) {
					header_img = 'https://whav.net/wp-content/uploads/2019/02/whav_header-768x120.png';
				} else if (screenWidth > 767 && screenWidth <= 979) {
					header_img = 'https://whav.net/wp-content/uploads/2019/02/whav_header-980x180.png';
				} else {
					header_img = 'https://whav.net/wp-content/uploads/2019/02/whav_header-1170x150-1170x150.png';
				}
				return header_img;
			}
			var banner_img_src = whichHeader();
		</script>
	<meta name='robots' content='max-image-preview:large' />
<script type="text/javascript" >            function apbct_attach_event_handler__backend(elem, event, callback){                if(typeof window.addEventListener === "function") elem.addEventListener(event, callback);                else                                              elem.attachEvent(event, callback);            }            apbct_attach_event_handler__backend(window, 'load', function(){                ctSetCookie('ct_checkjs', '687933542', '0');            });</script><link rel='dns-prefetch' href='//js.stripe.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//checkout.stripe.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="WHAV &raquo; Feed" href="https://whav.net/feed/" />
<link rel="alternate" type="application/rss+xml" title="WHAV &raquo; Comments Feed" href="https://whav.net/comments/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.10.4 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.10.4';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-1942200-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-1942200-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/whav.net\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://whav.net/wp-includes/css/dist/block-library/style.min.css?ver=5.7.1' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wpfc-css'  href='https://whav.net/wp-content/plugins/gs-facebook-comments/public/css/wpfc-public.css?ver=1.5' type='text/css' media='all' />
<link rel='stylesheet' id='swpm.common-css'  href='https://whav.net/wp-content/plugins/simple-membership/css/swpm.common.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='stripe-checkout-button-css'  href='https://checkout.stripe.com/v3/checkout/button.css' type='text/css' media='all' />
<link rel='stylesheet' id='simpay-public-css'  href='https://whav.net/wp-content/plugins/wp-simple-pay-pro-3/includes/core/assets/css/simpay-public.min.css?ver=4.0.0-beta-2' type='text/css' media='all' />
<link rel='stylesheet' id='simpay-jquery-ui-cupertino-css'  href='https://whav.net/wp-content/plugins/wp-simple-pay-pro-3/includes/pro/assets/css/vendor/jquery-ui/jquery-ui-cupertino.min.css?ver=4.0.0-beta-2' type='text/css' media='all' />
<link rel='stylesheet' id='simpay-public-pro-css'  href='https://whav.net/wp-content/plugins/wp-simple-pay-pro-3/includes/pro/assets/css/simpay-public-pro.min.css?ver=4.0.0-beta-2' type='text/css' media='all' />
<link rel='stylesheet' id='largo-stylesheet-css'  href='https://whav.net/wp-content/themes/largo-master/css/style.min.css?ver=0.5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='navis-slick-css'  href='https://whav.net/wp-content/themes/largo-master/lib/navis-slideshows/vendor/slick/slick.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='navis-slides-css'  href='https://whav.net/wp-content/themes/largo-master/lib/navis-slideshows/css/slides.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://whav.net/wp-content/plugins/tablepress/css/default.min.css?ver=1.12' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://whav.net/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=8.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://whav.net/wp-content/plugins/jetpack/css/jetpack.css?ver=8.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='ws-plugin--s2member-css'  href='https://whav.net/wp-content/plugins/s2member/s2member-o.php?ws_plugin__s2member_css=1&#038;qcABC=1&#038;ver=191022-191022-418948772' type='text/css' media='all' />
<script type='text/javascript' src='https://whav.net/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://whav.net/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://whav.net/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20191011' id='jetpack_related-posts-js'></script>
<script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/whav.net","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://whav.net/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.10.4' id='monsterinsights-frontend-script-js'></script>
<script type='text/javascript' id='ct_public-js-extra'>
/* <![CDATA[ */
var ctPublic = {"_ajax_nonce":"382f2a82d7","_rest_nonce":"81a05927f5","_ajax_url":"https:\/\/whav.net\/wp-admin\/admin-ajax.php","_rest_url":"https:\/\/whav.net\/wp-json\/","data__set_cookies":"1","data__set_cookies__sessions":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://whav.net/wp-content/plugins/cleantalk-spam-protect/js/apbct-public.min.js?apbct_ver=5.156&#038;ver=5.156' id='ct_public-js'></script>
<script type='text/javascript' src='https://whav.net/wp-content/plugins/cleantalk-spam-protect/js/cleantalk-modal.min.js?ver=5.156' id='cleantalk-modal-js'></script>
<script type='text/javascript' id='ct_nocache-js-extra'>
/* <![CDATA[ */
var ctNocache = {"ajaxurl":"https:\/\/whav.net\/wp-admin\/admin-ajax.php","info_flag":"","set_cookies_flag":"","blog_home":"https:\/\/whav.net\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://whav.net/wp-content/plugins/cleantalk-spam-protect/js/cleantalk_nocache.min.js?ver=5.156' id='ct_nocache-js'></script>
<script type='text/javascript' src='https://whav.net/wp-content/plugins/gs-facebook-comments/public/js/wpfc-public.js?ver=1.5' id='wpfc-js'></script>
<script type='text/javascript' src='https://whav.net/wp-content/themes/largo-master/js/load-more-posts.min.js?ver=0.5.5.3' id='load-more-posts-js'></script>
<script type='text/javascript' src='https://whav.net/wp-content/themes/largo-master/js/modernizr.custom.js?ver=0.5.5.3' id='largo-modernizr-js'></script>
<link rel="https://api.w.org/" href="https://whav.net/wp-json/" /><link rel="alternate" type="application/json" href="https://whav.net/wp-json/wp/v2/posts/365184" /><link rel="canonical" href="https://whav.net/2021/05/03/haverhill-marina-president-reports-trailer-broke-loose-causing-employees-facial-injury/" />
<link rel='shortlink' href='https://wp.me/p4WB9a-1x04' />
<link rel="alternate" type="application/json+oembed" href="https://whav.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwhav.net%2F2021%2F05%2F03%2Fhaverhill-marina-president-reports-trailer-broke-loose-causing-employees-facial-injury%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://whav.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwhav.net%2F2021%2F05%2F03%2Fhaverhill-marina-president-reports-trailer-broke-loose-causing-employees-facial-injury%2F&#038;format=xml" />
<link type="text/css" rel="stylesheet" href="https://whav.net/wp-content/plugins/category-specific-rss-feed-menu/wp_cat_rss_style.css" />
<meta property="fb:app_id" content="71134849954" />        <script type="text/javascript">
            jQuery(document).ready(function($) {
                $('#respond').html('<div class="swpm-login-to-comment-msg">Please login to comment.</div>');
            });
        </script>
        <script type='text/javascript'>window._taboola = window._taboola || [];
_taboola.push({article:'auto'});
_taboola.push({listenTo:'render',handler:function(p){TRC.modDebug.logMessageToServer(2,"wordpress-integ");}});
_taboola.push({additional_data:{sdkd:{
    "os" : "Wordpress",
    "osv" : "5.7.1",
    "sdkt" : "Taboola Wordpress Plugin",
    "sdkv" : "1.0.9"
}}});
!function (e, f, u) {
	e.async = 1;
  e.src = u;
  f.parentNode.insertBefore(e, f);
}(document.createElement('script'), document.getElementsByTagName('script')[0], '//cdn.taboola.com/libtrc/publicmediaofnewengland-network/loader.js');
</script><meta name="viewport" content="width=device-width, initial-scale=1" />
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<style type='text/css'>img#wpstats{display:none}</style>
		<meta name="twitter:card" content="summary">

		<meta name="twitter:site" content="@whavradio">
							<meta property="og:title" content="Haverhill Marina President Reports Trailer Broke Loose, Causing Employee’s Facial Injury" />
					<meta property="og:type" content="article" />
					<meta property="og:url" content="https://whav.net/2021/05/03/haverhill-marina-president-reports-trailer-broke-loose-causing-employees-facial-injury/"/>
					<meta property="og:description" content="The president of a Haverhill marina, where a man received “severe” facial injuries Saturday morning, said he and his staff are “all shocked and saddened by the accident.” Randall Bennett, president of Kazmiera Marina, told WHAV a marina “employee was moving a trailered boat with a fork truck that has a trailer ball attached for [&hellip;]" />
					<meta name="description" content="The president of a Haverhill marina, where a man received “severe” facial injuries Saturday morning, said he and his staff are “all shocked and saddened by the accident.” Randall Bennett, president of Kazmiera Marina, told WHAV a marina “employee was moving a trailered boat with a fork truck that has a trailer ball attached for [&hellip;]" />
			<meta property="og:site_name" content="WHAV" /><meta property="og:image" content="https://whav.net/wp-content/uploads/2015/05/randall_bennett.jpg" /><link rel="apple-touch-icon" href="https://whav.net/wp-content/uploads/2019/02/WHAV_square_979_512-1.png"/><link rel="shortcut icon" href="https://whav.net/wp-content/uploads/2019/02/WHAV_square_979_hybrid_embossed.ico"/><meta name="news_keywords" content="Haverhill"><meta name="original-source" content="https://whav.net/2021/05/03/haverhill-marina-president-reports-trailer-broke-loose-causing-employees-facial-injury/" /><meta name="syndication-source" content="https://whav.net/2021/05/03/haverhill-marina-president-reports-trailer-broke-loose-causing-employees-facial-injury/" /><meta name="standout" content="https://whav.net/2021/05/03/haverhill-marina-president-reports-trailer-broke-loose-causing-employees-facial-injury/"/><link rel="icon" href="https://whav.net/wp-content/uploads/2019/02/cropped-WHAV_square_979_512-32x32.png" sizes="32x32" />
<link rel="icon" href="https://whav.net/wp-content/uploads/2019/02/cropped-WHAV_square_979_512-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://whav.net/wp-content/uploads/2019/02/cropped-WHAV_square_979_512-180x180.png" />
<meta name="msapplication-TileImage" content="https://whav.net/wp-content/uploads/2019/02/cropped-WHAV_square_979_512-270x270.png" />

<!-- START - Open Graph and Twitter Card Tags 3.0.0 -->
 <!-- Facebook Open Graph -->
  <meta property="og:locale" content="en_US"/>
  <meta property="og:site_name" content="WHAV"/>
  <meta property="og:title" content="Haverhill Marina President Reports Trailer Broke Loose, Causing Employee’s Facial Injury"/>
  <meta property="og:url" content="https://whav.net/2021/05/03/haverhill-marina-president-reports-trailer-broke-loose-causing-employees-facial-injury/"/>
  <meta property="og:type" content="article"/>
  <meta property="og:description" content="The president of a Haverhill marina, where a man received “severe” facial injuries Saturday morning, said he and his staff are “all shocked and saddened by the accident.”

Randall Bennett, president of Kazmiera Marina, told WHAV a marina “employee was moving a trailered boat with a fork truck that"/>
  <meta property="og:image" content="https://whav.net/wp-content/uploads/2015/05/randall_bennett.jpg"/>
  <meta property="og:image:url" content="https://whav.net/wp-content/uploads/2015/05/randall_bennett.jpg"/>
  <meta property="og:image:secure_url" content="https://whav.net/wp-content/uploads/2015/05/randall_bennett.jpg"/>
  <meta property="article:published_time" content="2021-05-03T00:03:08-04:00"/>
  <meta property="article:modified_time" content="2021-05-02T19:52:38-04:00" />
  <meta property="og:updated_time" content="2021-05-02T19:52:38-04:00" />
  <meta property="article:section" content="Haverhill"/>
 <!-- Google+ / Schema.org -->
  <meta itemprop="name" content="Haverhill Marina President Reports Trailer Broke Loose, Causing Employee’s Facial Injury"/>
  <meta itemprop="headline" content="Haverhill Marina President Reports Trailer Broke Loose, Causing Employee’s Facial Injury"/>
  <meta itemprop="description" content="The president of a Haverhill marina, where a man received “severe” facial injuries Saturday morning, said he and his staff are “all shocked and saddened by the accident.”

Randall Bennett, president of Kazmiera Marina, told WHAV a marina “employee was moving a trailered boat with a fork truck that"/>
  <meta itemprop="image" content="https://whav.net/wp-content/uploads/2015/05/randall_bennett.jpg"/>
  <meta itemprop="datePublished" content="2021-05-03"/>
  <meta itemprop="dateModified" content="2021-05-02T19:52:38-04:00" />
  <meta itemprop="author" content="News Editor"/>
 <!-- Twitter Cards -->
  <meta name="twitter:title" content="Haverhill Marina President Reports Trailer Broke Loose, Causing Employee’s Facial Injury"/>
  <meta name="twitter:url" content="https://whav.net/2021/05/03/haverhill-marina-president-reports-trailer-broke-loose-causing-employees-facial-injury/"/>
  <meta name="twitter:card" content="summary_large_image"/>
 <!-- SEO -->
  <link rel="canonical" href="https://whav.net/2021/05/03/haverhill-marina-president-reports-trailer-broke-loose-causing-employees-facial-injury/"/>
 <!-- Misc. tags -->
 <!-- is_singular -->
<!-- END - Open Graph and Twitter Card Tags 3.0.0 -->
	
</head>

<body class="post-template-default single single-post postid-365184 single-format-standard classic">

	<div id="top"></div>

	
		<div class="global-nav-bg">
		<div class="global-nav">
			<nav id="top-nav" class="span12">
				<span class="visuallyhidden">
					<a href="#main" title="Skip to content">Skip to content</a>
				</span>
				<ul id="menu-global-navigation" class="menu"><li id="menu-item-50137" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50137"><a title="Opens pop-up player window" target="_blank" rel="noopener" href="http://player.streamguys.com/whav/sgplayer3/player.php">Listen Live</a></li>
<li id="menu-item-310522" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-310522"><a href="https://whav.net//wp-login.php">Admin Log-In</a></li>
</ul>				<div class="nav-right">
											<ul id="header-social" class="social-icons visible-desktop">
							<li><a href="https://www.facebook.com/pages/WHAV/56895487142" title="Link to Facebook Profile"><i class="icon-facebook"></i></a></li><li><a href="https://twitter.com/whavradio" title="Link to Twitter Page"><i class="icon-twitter"></i></a></li><li><a href="https://www.youtube.com/channel/UCBFlOKPkIoviQc1X9p91_6Q" title="Link to YouTube Page"><i class="icon-youtube"></i></a></li><li><a href="https://www.instagram.com/whavradio/" title="Link to Instagram Page"><i class="icon-instagram"></i></a></li><li><a href="https://whavradio.tumblr.com/" title="Link to Tumblr"><i class="icon-tumblr"></i></a></li><li><a href="https://www.linkedin.com/company/whav" title="Link to LinkedIn Page"><i class="icon-linkedin"></i></a></li><li><a href="https://whav.net/feed/" title="Link to RSS Feed"><i class="icon-rss"></i></a></li>						</ul>
					<div class="donate-btn"><a href="https://whav.net/become-a-whav-member/"><i class="icon-heart"></i>Donate Now</a></div> 					<!-- BEGIN Header Search -->
					<div id="header-search">
						<form class="form-search" role="search" method="get" action="https://whav.net/">
							<div class="input-append">
								<input type="text" placeholder="Search" class="input-medium appendedInputButton search-query" value="" name="s" /><button type="submit" class="search-submit btn">GO</button>
							</div>
						</form>
					</div>
				<!-- END Header Search -->
				</div>
			</nav>
		</div> <!-- /.global-nav -->
	</div> <!-- /.global-nav-bg -->

	<div id="page" class="hfeed clearfix">

		 <div class="sticky-nav-wrapper nocontent">
	<div class="sticky-nav-holder">

	
		<div class="sticky-nav-container">
			<nav id="sticky-nav" class="sticky-navbar navbar clearfix">
				<div class="container">
					<div class="nav-right">
											<ul id="header-social" class="social-icons visible-desktop">
							<li><a href="https://www.facebook.com/pages/WHAV/56895487142" title="Link to Facebook Profile"><i class="icon-facebook"></i></a></li><li><a href="https://twitter.com/whavradio" title="Link to Twitter Page"><i class="icon-twitter"></i></a></li><li><a href="https://www.youtube.com/channel/UCBFlOKPkIoviQc1X9p91_6Q" title="Link to YouTube Page"><i class="icon-youtube"></i></a></li><li><a href="https://www.instagram.com/whavradio/" title="Link to Instagram Page"><i class="icon-instagram"></i></a></li><li><a href="https://whavradio.tumblr.com/" title="Link to Tumblr"><i class="icon-tumblr"></i></a></li><li><a href="https://www.linkedin.com/company/whav" title="Link to LinkedIn Page"><i class="icon-linkedin"></i></a></li><li><a href="https://whav.net/feed/" title="Link to RSS Feed"><i class="icon-rss"></i></a></li>						</ul>
					
						<ul id="header-extras">
															<li class="donate">
									<a class="donate-link" href="https://whav.net/become-a-whav-member/">
										<span><i class="icon-heart"></i>Donate Now</span>
									</a>
								</li>							<li id="sticky-nav-search">
								<a href="#" class="toggle">
									<i class="icon-search" title="Search" role="button"></i>
								</a>
								<form class="form-search" role="search" method="get" action="https://whav.net/">
									<div class="input-append">
										<span class="text-input-wrapper">
											<input type="text" placeholder="Search"
												class="input-medium appendedInputButton search-query" value="" name="s" />
										</span>
										<button type="submit" class="search-submit btn">Go</button>
									</div>
								</form>
							</li>
														<li>
								<!-- "hamburger" button (3 bars) to trigger off-canvas navigation -->
								<a class="btn btn-navbar toggle-nav-bar" title="More">
									<div class="bars">
										<span class="icon-bar"></span>
										<span class="icon-bar"></span>
										<span class="icon-bar"></span>
									</div>
								</a>
							</li>
						</ul>

					</div>

					<!-- BEGIN MOBILE MENU (hidden on desktop) -->
					<div class="nav-left">
													<ul>
								<li class="home-icon"><a href="https://whav.net/"><img src="https://whav.net/wp-content/uploads/2019/02/whav_header-640x100.png" class="attachment-home-logo" alt="logo"></a></li>
							</ul>
											</div>
					<!-- END MOBILE MENU -->

					<!-- BEGIN DESKTOP MENU -->
					<div class="nav-shelf">
					<ul class="nav">
													<li class="home-icon">
								<a href="https://whav.net/">
									<img src="https://whav.net/wp-content/uploads/2019/02/whav_header-640x100.png" class="attachment-home-logo" alt="logo">								</a>
							</li>
						<li id="menu-item-243" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-243"><a href="https://whav.net/">Home</a></li>
<li id="menu-item-1074" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-1074"><a class="dropdown-toggle">Local News <b class="caret"></b></a></a>
<ul class="dropdown-menu">
	<li id="menu-item-2812" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2812"><a href="https://whav.net/category/localnews/haverhill/">Haverhill</a></li>
	<li id="menu-item-2089" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2089"><a href="https://whav.net/category/localnews/region/">Region</a></li>
	<li id="menu-item-42450" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42450"><a href="https://whav.net/category/localnews/crime/">Crime</a></li>
	<li id="menu-item-10340" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10340"><a href="https://whav.net/category/localnews/education/">Education</a></li>
	<li id="menu-item-42452" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42452"><a href="https://whav.net/category/whavinvestigates/">WHAV Investigates</a></li>
	<li id="menu-item-40830" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40830"><a href="https://whav.net/category/localnews/state-house-news/">State House News</a></li>
	<li id="menu-item-1212" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1212"><a href="https://whav.net/weather/">Weather</a></li>
</ul>
</li>
<li id="menu-item-937" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-937"><a href="https://whav.net/category/communityspotlight/" class="dropdown-toggle">Community Spotlight <b class="caret"></b></a></a>
<ul class="dropdown-menu">
	<li id="menu-item-1115" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1115"><a href="https://whav.net/submit-news-tip/">Submit News Tip or Community Spotlight</a></li>
</ul>
</li>
<li id="menu-item-42453" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-42453"><a class="dropdown-toggle">People &#038; Places <b class="caret"></b></a></a>
<ul class="dropdown-menu">
	<li id="menu-item-244" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-244"><a href="https://whav.net/category/business/">Business Bulletin</a></li>
	<li id="menu-item-40831" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40831"><a href="https://whav.net/category/places/">Going Out</a></li>
	<li id="menu-item-25229" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25229"><a href="https://whav.net/category/sports/">Sports</a></li>
	<li id="menu-item-2160" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2160"><a href="https://whav.net/category/haverhill-heritage-series/">Haverhill Heritage Series</a></li>
	<li id="menu-item-183033" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-183033"><a href="https://whav.net/category/obituaries/">Obituaries</a></li>
	<li id="menu-item-238869" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-238869"><a href="https://whav.net/category/letters/">Letters</a></li>
</ul>
</li>
<li id="menu-item-344233" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-344233"><a class="dropdown-toggle">Membership <b class="caret"></b></a></a>
<ul class="dropdown-menu">
	<li id="menu-item-1130" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1130"><a href="https://whav.net/become-a-whav-member/">Membership</a></li>
	<li id="menu-item-363060" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-363060"><a href="https://whav.net/wavelengths-local-news-daily/">Wavelengths Local News Daily</a></li>
	<li id="menu-item-344230" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-344230"><a href="https://whav.net/member-update/">Member Update Form</a></li>
</ul>
</li>
<li id="menu-item-1081" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-1081"><a class="dropdown-toggle">Radio, Podcasts, TV <b class="caret"></b></a></a>
<ul class="dropdown-menu">
	<li id="menu-item-44123" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44123"><a href="https://whav.net/category/press/">What&#8217;s On?</a></li>
	<li id="menu-item-1108" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1108"><a href="https://whav.net/listen/">Listen</a></li>
	<li id="menu-item-142599" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-142599"><a href="https://whav.net/merrimack-valley-newsmakers-podcasts/">Hear It Again (Podcasts)</a></li>
	<li id="menu-item-1111" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1111"><a href="https://whav.net/watch/">Watch</a></li>
</ul>
</li>
<li id="menu-item-1078" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-1078"><a class="dropdown-toggle">Info. &#038; Contacts <b class="caret"></b></a></a>
<ul class="dropdown-menu">
	<li id="menu-item-1267" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1267"><a href="https://whav.net/general-inquiries/">General Inquiries</a></li>
	<li id="menu-item-22290" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22290"><a href="https://whav.net/submit-news-tip/">Submit News Tip or Community Spotlight</a></li>
	<li id="menu-item-28846" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28846"><a href="https://whav.net/submit-obituary/">Submit Obituary</a></li>
	<li id="menu-item-25166" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25166"><a href="https://whav.net/media-sponsorship-request/">Media Sponsorship Request</a></li>
	<li id="menu-item-92489" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-92489"><a>Careers <i class="icon-arrow-right"></i></a>
	<ul class="dropdown-menu sub-menu">
		<li id="menu-item-63743" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-63743"><a href="https://whav.net/category/employment/">Job Openings</a></li>
		<li id="menu-item-19784" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19784"><a href="https://whav.net/jobs/">Job Application</a></li>
	</ul>
</li>
	<li id="menu-item-92488" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-92488"><a>About WHAV <i class="icon-arrow-right"></i></a>
	<ul class="dropdown-menu sub-menu">
		<li id="menu-item-1220" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1220"><a href="https://whav.net/staff/">Staff</a></li>
		<li id="menu-item-1250" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1250"><a href="https://whav.net/history/">History</a></li>
		<li id="menu-item-39663" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39663"><a href="https://whav.net/news-policy/">News Policy</a></li>
		<li id="menu-item-39671" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39671"><a href="https://whav.net/general-contest-rules/">General Contest Rules</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-1259" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1259"><a href="https://whav.net/underwriting/">Advertising</a></li>
								<li class="donate">
									<a class="donate-link" href="https://whav.net/become-a-whav-member/">
										<span>Donate Now</span>
									</a>
								</li>									<li class="menu-item menu-item-has-childen dropdown">
										<a href="javascript:void(0);" class="dropdown-toggle">Global Navigation <b class="caret"></b>
										</a>
										<ul id="menu-global-navigation-1" class="dropdown-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50137"><a title="Opens pop-up player window" target="_blank" rel="noopener" href="http://player.streamguys.com/whav/sgplayer3/player.php">Listen Live</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-310522"><a href="https://whav.net//wp-login.php">Admin Log-In</a></li>
</ul>									</li>
																					</ul>
					</div>
				</div>
			</nav>
		</div>
	</div>
</div>
<header id="site-header" class="clearfix nocontent" itemscope itemtype="http://schema.org/Organization">
	
				<h2 class="visuallyhidden">
					<a itemprop="url" href="https://whav.net/">
						<span class="sitename" itemprop="name">WHAV</span>
						<span class="tagline" itemprop="description"> - The Only Haverhill-Based News Source</span>
					</a>
				</h2>
			<a itemprop="url" href="https://whav.net/"><img class="header_img" src="" alt="" /></a><meta itemprop="logo" content="https://whav.net/wp-content/uploads/2019/02/WHAV_square_979_512-1.png"/></header>
<header class="print-header nocontent">
	<p>
		<strong>WHAV</strong>
		(https://whav.net/2021/05/03/haverhill-marina-president-reports-trailer-broke-loose-causing-employees-facial-injury/)
	</p>
</header>
<nav id="main-nav" class="navbar clearfix">
	<div class="navbar-inner">
		<div class="container">
			
						
			<div class="nav-shelf">
				<ul class="nav">
				
				<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-243"><a href="https://whav.net/">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-1074"><a class="dropdown-toggle">Local News <b class="caret"></b></a></a>
<ul class="dropdown-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2812"><a href="https://whav.net/category/localnews/haverhill/">Haverhill</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2089"><a href="https://whav.net/category/localnews/region/">Region</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42450"><a href="https://whav.net/category/localnews/crime/">Crime</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10340"><a href="https://whav.net/category/localnews/education/">Education</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42452"><a href="https://whav.net/category/whavinvestigates/">WHAV Investigates</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40830"><a href="https://whav.net/category/localnews/state-house-news/">State House News</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1212"><a href="https://whav.net/weather/">Weather</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-937"><a href="https://whav.net/category/communityspotlight/" class="dropdown-toggle">Community Spotlight <b class="caret"></b></a></a>
<ul class="dropdown-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1115"><a href="https://whav.net/submit-news-tip/">Submit News Tip or Community Spotlight</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-42453"><a class="dropdown-toggle">People &#038; Places <b class="caret"></b></a></a>
<ul class="dropdown-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-244"><a href="https://whav.net/category/business/">Business Bulletin</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40831"><a href="https://whav.net/category/places/">Going Out</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25229"><a href="https://whav.net/category/sports/">Sports</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2160"><a href="https://whav.net/category/haverhill-heritage-series/">Haverhill Heritage Series</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-183033"><a href="https://whav.net/category/obituaries/">Obituaries</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-238869"><a href="https://whav.net/category/letters/">Letters</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-344233"><a class="dropdown-toggle">Membership <b class="caret"></b></a></a>
<ul class="dropdown-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1130"><a href="https://whav.net/become-a-whav-member/">Membership</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-363060"><a href="https://whav.net/wavelengths-local-news-daily/">Wavelengths Local News Daily</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-344230"><a href="https://whav.net/member-update/">Member Update Form</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-1081"><a class="dropdown-toggle">Radio, Podcasts, TV <b class="caret"></b></a></a>
<ul class="dropdown-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44123"><a href="https://whav.net/category/press/">What&#8217;s On?</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1108"><a href="https://whav.net/listen/">Listen</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-142599"><a href="https://whav.net/merrimack-valley-newsmakers-podcasts/">Hear It Again (Podcasts)</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1111"><a href="https://whav.net/watch/">Watch</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-1078"><a class="dropdown-toggle">Info. &#038; Contacts <b class="caret"></b></a></a>
<ul class="dropdown-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1267"><a href="https://whav.net/general-inquiries/">General Inquiries</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22290"><a href="https://whav.net/submit-news-tip/">Submit News Tip or Community Spotlight</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28846"><a href="https://whav.net/submit-obituary/">Submit Obituary</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25166"><a href="https://whav.net/media-sponsorship-request/">Media Sponsorship Request</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-92489"><a>Careers <i class="icon-arrow-right"></i></a>
	<ul class="dropdown-menu sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-63743"><a href="https://whav.net/category/employment/">Job Openings</a></li>
		<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19784"><a href="https://whav.net/jobs/">Job Application</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-92488"><a>About WHAV <i class="icon-arrow-right"></i></a>
	<ul class="dropdown-menu sub-menu">
		<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1220"><a href="https://whav.net/staff/">Staff</a></li>
		<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1250"><a href="https://whav.net/history/">History</a></li>
		<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39663"><a href="https://whav.net/news-policy/">News Policy</a></li>
		<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39671"><a href="https://whav.net/general-contest-rules/">General Contest Rules</a></li>
	</ul>
</li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1259"><a href="https://whav.net/underwriting/">Advertising</a></li>
				</ul>

			</div>
			
						
		</div>
	</div>
</nav>

		<div id="main" class="row-fluid clearfix">

		
<div id="content" class="span8" role="main">
	
<article id="post-365184" class="hnews item post-365184 post type-post status-publish format-standard has-post-thumbnail hentry category-haverhill prominence-homepage-featured prominence-top-story featured-media featured-media-image" itemscope itemtype="http://schema.org/Article">

	
	<header>

		<h1 class="entry-title" itemprop="headline">Haverhill Marina President Reports Trailer Broke Loose, Causing Employee’s Facial Injury</h1>
				<h5 class="byline"><span class="by-author"><span class="by">By</span> <span class="author vcard" itemprop="author">WHAV Staff</span></span><span class="sep"> |</span> <time class="entry-date updated dtstamp pubdate" datetime="2021-05-03T00:03:08-04:00"><span class="time-ago">2 hours ago</span></time></h5>

		
		<meta itemprop="description" content="

The president of a Haverhill marina, where a man received “severe” facial injuries Saturday morning, said he and his staff are “all shocked and saddened by the accident.”
Randall Bennett, president of Kazmiera Marina, told WHAV a marina “employee was moving a trailered boat with a fork truck that has a trailer ball attached for that purpose, as he does 200 times a year. He had two other employees working as spotters to block any traffic and guide him.”
“The trailer broke loose and kept rolling. He brought the fork truck to the front of the boat and accidentally hit the boat with a mirror on the fork truck. The mirror then hit him in the face and broke his jaw. He asked another employee to call 911 and the fire department arrived within minutes,” Bennett added. 
window._taboola = window._taboola || [];
_taboola.push({mode:'thumbnails-a', container:'taboola-below-article', placement:'below-article', target_type: 'mix'});Share this:PrintFacebookTwitterLinkedInRedditTumblrSkypeWhatsAppPinterestLike this:Like Loading...

	Related

" />
<meta itemprop="datePublished" content="2021-05-03T00:03:08-04:00" />
<meta itemprop="dateModified" content="2021-05-02T19:52:38-04:00" />
<meta itemprop="image" content="https://whav.net/wp-content/uploads/2015/05/randall_bennett-110x110.jpg" />
	</header><!-- / entry header -->

	<div class="hero is-image ">
	<img width="500" height="400" src="https://whav.net/wp-content/uploads/2015/05/randall_bennett.jpg" class="attachment-full size-full wp-post-image" alt="" loading="lazy" />				<p class="wp-caption-text">Randall Bennett, president of Kazmiera Marina. (WHAV News file photograph.)</p>
		</div>

	<div class="entry-content clearfix" itemprop="articleBody">
		<div class='code-block code-block-5' style='margin: 8px 0; clear: both;'>
<a href="https://ssjmattorneys.com/" target="_blank"><img src="https://whav.net/wp-content/uploads/2017/04/ssjm_ad_770x90.jpg"></a></div>
<p>The president of a Haverhill marina, where a man received “severe” facial injuries Saturday morning, said he and his staff are “all shocked and saddened by the accident.”</p>
<p>Randall Bennett, president of Kazmiera Marina, told WHAV a marina “employee was moving a trailered boat with a fork truck that has a trailer ball attached for that purpose, as he does 200 times a year. He had two other employees working as spotters to block any traffic and guide him.”</p>
<p>“The trailer broke loose and kept rolling. He brought the fork truck to the front of the boat and accidentally hit the boat with a mirror on the fork truck. The mirror then hit him in the face and broke his jaw. He asked another employee to call 911 and the fire department arrived within minutes,” Bennett added.</p>
<p>Bennett said a customer of the marina, who is also an emergency medical technician was only 40 feet away and administered first aid immediately. He said the technician talked with the 911 operator until the fire department took control.</p>
<p>Fire Chief Robert M. O’Brien told WHAV over the weekend the Haverhill Fire Department’s Engine 3, Rescue 1 and Car 2 from the Water Street station were dispatched just before 7:30 a.m. to the marina at 72 Coffin Ave.</p>
<p>O’Brien said firefighters arrived and found “a gentleman face down with severe injuries in and about the face area. There was no entrapment and no one was pinned at the time.”</p>
<p>O’Brien added firefighters administered initial medical care and then the unidentified man was taken by Trinity EMS to Lawrence General Hospital and later airlifted to a Boston-area hospital.</p>
<div id='taboola-below-article'></div><script type='text/javascript'>window._taboola = window._taboola || [];
_taboola.push({mode:'thumbnails-a', container:'taboola-below-article', placement:'below-article', target_type: 'mix'});</script><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon" href="https://whav.net/2021/05/03/haverhill-marina-president-reports-trailer-broke-loose-causing-employees-facial-injury/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-365184" class="share-facebook sd-button share-icon" href="https://whav.net/2021/05/03/haverhill-marina-president-reports-trailer-broke-loose-causing-employees-facial-injury/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-365184" class="share-twitter sd-button share-icon" href="https://whav.net/2021/05/03/haverhill-marina-president-reports-trailer-broke-loose-causing-employees-facial-injury/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-365184" class="share-linkedin sd-button share-icon" href="https://whav.net/2021/05/03/haverhill-marina-president-reports-trailer-broke-loose-causing-employees-facial-injury/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://whav.net/2021/05/03/haverhill-marina-president-reports-trailer-broke-loose-causing-employees-facial-injury/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon" href="https://whav.net/2021/05/03/haverhill-marina-president-reports-trailer-broke-loose-causing-employees-facial-injury/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-skype"><a rel="nofollow noopener noreferrer" data-shared="sharing-skype-365184" class="share-skype sd-button share-icon" href="https://whav.net/2021/05/03/haverhill-marina-president-reports-trailer-broke-loose-causing-employees-facial-injury/?share=skype" target="_blank" title="Click to share on Skype"><span>Skype</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon" href="https://whav.net/2021/05/03/haverhill-marina-president-reports-trailer-broke-loose-causing-employees-facial-injury/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span>WhatsApp</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-365184" class="share-pinterest sd-button share-icon" href="https://whav.net/2021/05/03/haverhill-marina-president-reports-trailer-broke-loose-causing-employees-facial-injury/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-73071164-365184-608f8e89c5ba3' data-src='https://widgets.wp.com/likes/#blog_id=73071164&amp;post_id=365184&amp;origin=whav.net&amp;obj_id=73071164-365184-608f8e89c5ba3' data-name='like-post-frame-73071164-365184-608f8e89c5ba3'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div><!-- AI CONTENT END 4 -->
	</div><!-- .entry-content -->

	
	<footer class="post-meta bottom-meta">

	</footer><!-- /.post-meta -->

	
</article><!-- #post-365184 -->
	<div id="comments" class="clearfix">
	
	
			<p class="nocomments notice">Comments are closed.</p>
	
	
</div><!-- #comments -->
</div>


<aside id="sidebar" class="span4 nocontent">
		<div class="widget-area" role="complementary">
		<aside id="text-156" class="widget widget-1 odd default widget_text clearfix">			<div class="textwidget"><div class="sgplayer" style="width: 400px; height: 400px; display: inline-block;"><iframe style="width: inherit; height: inherit; border: 0;" src="https://player.streamguys.com/whav/sgplayer3/player.php?l=layout-standard" frameborder="0" scrolling="no" allowfullscreen="true"></iframe></div>
</div>
		</aside><aside id="text-167" class="widget widget-2 even default widget_text clearfix">			<div class="textwidget"><style>
.ads-230x230 {<br />  text-align: center;<br />  background: ;<br />  height: 232px;<br />  line-height: 232px;<br />  max-width: 230px;<br />  width: 100%;<br />  display: block;<br />  margin:0 auto;<br />  }</p>
<p>  .ads-230x232 a {<br />  color: #666;<br />  }<br />  </style>
<div class="ads-230x232"><a href="https://www.elainedaltonlaw.com/" target="_blank" rel="noopener"><img src="https://whav.net/wp-content/uploads/2021/01/elaine_dalton-230x230_v3.png" /></a></div>
<div></div>
</div>
		</aside><aside id="text-174" class="widget widget-3 odd default widget_text clearfix">			<div class="textwidget"><p><a href="http://haverhillfamilyhealthcenter.org/" target="_blank" rel="noopener"><img src="https://whav.net/wp-content/uploads/2020/10/GLFHC_Haverhill_1.jpg" /></a></p>
</div>
		</aside><aside id="text-181" class="widget widget-4 even default widget_text clearfix">			<div class="textwidget"><p><a href="https://www.cedarsfoods.com/Careers.aspx" target="_blank" rel="noopener"><img src="https://whav.net/wp-content/uploads/2021/04/Cedars-Now-Hiring-Ad-230x230-1.jpg" /></a></p>
</div>
		</aside><aside id="text-183" class="widget widget-5 odd default widget_text clearfix">			<div class="textwidget"><p><a href="http://haverhillsaves.org/" target="_blank" rel="noopener"><img src="https://whav.net/wp-content/uploads/2021/04/energy-program.jpg" /></a></p>
</div>
		</aside><aside id="text-176" class="widget widget-6 even default widget_text clearfix">			<div class="textwidget"><style>
.ads-230 {<br />  text-align: center;<br />  background: ;<br />  height: 60px;<br />  line-height: 60px;<br />  max-width: 230px;<br />  width: 100%;<br />  display: block;<br />  margin:0 auto;<br />  }</p>
<p>  .ads-230 a {<br />  color: #666;<br />  }<br />  </style>
<div class=""><a href="http://www.climatezone.biz/" target="_blank" rel="noopener"><img src="https://whav.net/wp-content/uploads/2014/10/CZBanner_230X58.jpg" /></a><br />
<a href="https://whav.net/wp-content/uploads/2015/11/Climate-Zone-COLD.mp3" target="_blank" rel="noopener"><img src="https://whav.net/wp-content/uploads/2015/05/click_to_hear_banner.png" /></a></div>
</div>
		</aside><aside id="text-179" class="widget widget-7 odd default widget_text clearfix">			<div class="textwidget"><p><a href="https://www.coldwellbanker.com/Coldwell-Banker-Realty-12681c/Lisa-Corr-7510793a/" target="_blank" rel="noopener"><img src="https://whav.net/wp-content/uploads/2020/10/lisa_corr_230x60.png" /></a></p>
</div>
		</aside><aside id="text-158" class="widget widget-8 even default widget_text clearfix"><h3 class="widgettitle">Click to Donate Now!</h3>			<div class="textwidget"><p><a href="https://whav.net/become-a-whav-member/" target="_blank" rel="noopener"><img src="https://whav.net/wp-content/uploads/2019/02/become_a-member-230x230-1.png" /></a></p>
</div>
		</aside><aside id="text-152" class="widget widget-9 odd default widget_text clearfix">			<div class="textwidget"><p><a href="http://www.jcedwardslaw.com" target="_blank" rel="noopener"><img src="https://whav.net/wp-content/uploads/2017/10/3-26-17-edwards_law_230x230.png" /></a></p>
</div>
		</aside>      <aside id="mailpoet_form-3" class="widget widget-10 even default widget_mailpoet_form clearfix">
  
      <h3 class="widgettitle">Free Local News by Email</h3>
  
  <div class="
    mailpoet_form_popup_overlay
      "></div>
  <div
    id="mailpoet_form_2"
    class="
      mailpoet_form
      mailpoet_form_widget
      mailpoet_form_position_
      mailpoet_form_animation_
    "
      >
        <style type="text/css">.mailpoet_hp_email_label{display:none!important;}#mailpoet_form_2 .mailpoet_form {  }
#mailpoet_form_2 .mailpoet_paragraph { line-height: 20px; }
#mailpoet_form_2 .mailpoet_segment_label, #mailpoet_form_2 .mailpoet_text_label, #mailpoet_form_2 .mailpoet_textarea_label, #mailpoet_form_2 .mailpoet_select_label, #mailpoet_form_2 .mailpoet_radio_label, #mailpoet_form_2 .mailpoet_checkbox_label, #mailpoet_form_2 .mailpoet_list_label, #mailpoet_form_2 .mailpoet_date_label { display: block; font-weight: bold; }
#mailpoet_form_2 .mailpoet_text, #mailpoet_form_2 .mailpoet_textarea, #mailpoet_form_2 .mailpoet_select, #mailpoet_form_2 .mailpoet_date_month, #mailpoet_form_2 .mailpoet_date_day, #mailpoet_form_2 .mailpoet_date_year, #mailpoet_form_2 .mailpoet_date { display: block; }
#mailpoet_form_2 .mailpoet_text, #mailpoet_form_2 .mailpoet_textarea { width: 200px; }
#mailpoet_form_2 .mailpoet_checkbox {  }
#mailpoet_form_2 .mailpoet_submit input {  }
#mailpoet_form_2 .mailpoet_divider {  }
#mailpoet_form_2 .mailpoet_message {  }
#mailpoet_form_2 .mailpoet_validate_success { font-weight: 600; color: #468847; }
#mailpoet_form_2 .mailpoet_validate_error { color: #b94a48; }
#mailpoet_form_2 .mailpoet_form_loading { width: 30px; text-align: center; line-height: normal; }
#mailpoet_form_2 .mailpoet_form_loading > span { width: 5px; height: 5px; background-color: #5b5b5b; }#mailpoet_form_2{border-radius: 0px;text-align: left;}#mailpoet_form_2 form.mailpoet_form {padding: 20px;}#mailpoet_form_2{width: 100%;}#mailpoet_form_2 .mailpoet_message {margin: 0; padding: 0 20px;}#mailpoet_form_2 .mailpoet_paragraph.last {margin-bottom: 0} @media (max-width: 500px) {#mailpoet_form_2 {background-image: none;}} @media (min-width: 500px) {#mailpoet_form_2 .last .mailpoet_paragraph:last-child {margin-bottom: 0}}  @media (max-width: 500px) {#mailpoet_form_2 .mailpoet_form_column:last-child .mailpoet_paragraph:last-child {margin-bottom: 0}} </style>
    <form
      target="_self"
      method="post"
      action="https://whav.net/wp-admin/admin-post.php?action=mailpoet_subscription_form"
      class="mailpoet_form mailpoet_form_form mailpoet_form_widget"
      novalidate
      data-delay=""
      data-exit-intent-enabled=""
      data-font-family=""
    >
      <input type="hidden" name="data[form_id]" value="2" />
      <input type="hidden" name="token" value="fbd8b54fb1" />
      <input type="hidden" name="api_version" value="v1" />
      <input type="hidden" name="endpoint" value="subscribers" />
      <input type="hidden" name="mailpoet_method" value="subscribe" />

      <label class="mailpoet_hp_email_label">Please leave this field empty<input type="email" name="data[email]"/></label><div class="mailpoet_paragraph "><label class="mailpoet_text_label" data-automation-id="form_first_name_label" >First name</label><input type="text" class="mailpoet_text" name="data[form_field_OTRiNTc5MTZhYmU3X2ZpcnN0X25hbWU=]" title="First name" value="" style="padding:5px;margin: 0 auto 0 0;" data-automation-id="form_first_name" /></div>
<div class="mailpoet_paragraph "><label class="mailpoet_text_label" data-automation-id="form_email_label" >Email <span class="mailpoet_required">*</span></label><input type="email" class="mailpoet_text" name="data[form_field_NzQ0ZjZjMzZlYmU0X2VtYWls]" title="Email" value="" style="padding:5px;margin: 0 auto 0 0;" data-automation-id="form_email" data-parsley-required="true" data-parsley-minlength="6" data-parsley-maxlength="150" data-parsley-error-message="Please specify a valid email address." data-parsley-required-message="This field is required."/></div>
<div class="mailpoet_paragraph "><label class="mailpoet_segment_label" >Select list(s):</label><label class="mailpoet_checkbox_label" ><input type="checkbox" class="mailpoet_checkbox" name="data[form_field_MTY4YzFkOWIxN2JkX3NlZ21lbnRz][]" value="5"  data-parsley-required="true" data-parsley-group="segments" data-parsley-errors-container=".mailpoet_error_segments" data-parsley-required-message="Please select a list" /> WHAV News Daily Headlines</label><label class="mailpoet_checkbox_label" ><input type="checkbox" class="mailpoet_checkbox" name="data[form_field_MTY4YzFkOWIxN2JkX3NlZ21lbnRz][]" value="6"  data-parsley-required="true" data-parsley-group="segments" data-parsley-errors-container=".mailpoet_error_segments" data-parsley-required-message="Please select a list" /> WHAV Extra (breaking news alerts &amp; monthly)</label><span class="mailpoet_error_segments"></span></div>
<div class="mailpoet_recaptcha" data-sitekey="6Lezg5AUAAAAANnqmawYsPqYHgeJUzUjR3JvMQHT">
      <div class="mailpoet_recaptcha_container"></div>
      <noscript>
        <div>
          <div style="width: 302px; height: 422px; position: relative;">
            <div style="width: 302px; height: 422px; position: absolute;">
              <iframe src="https://www.google.com/recaptcha/api/fallback?k=6Lezg5AUAAAAANnqmawYsPqYHgeJUzUjR3JvMQHT" frameborder="0" scrolling="no" style="width: 302px; height:422px; border-style: none;">
              </iframe>
            </div>
          </div>
          <div style="width: 300px; height: 60px; border-style: none; bottom: 12px; left: 25px; margin: 0px; padding: 0px; right: 25px; background: #f9f9f9; border: 1px solid #c1c1c1; border-radius: 3px;">
            <textarea id="g-recaptcha-response" name="data[recaptcha]" class="g-recaptcha-response" style="width: 250px; height: 40px; border: 1px solid #c1c1c1; margin: 10px 25px; padding: 0px; resize: none;" >
            </textarea>
          </div>
        </div>
      </noscript>
      <input class="mailpoet_recaptcha_field" type="hidden" name="recaptcha">
    </div><div class="mailpoet_paragraph "><input type="submit" class="mailpoet_submit" value="Subscribe!" data-automation-id="subscribe-submit-button" style="padding:5px;margin: 0 auto 0 0;border-color:transparent;" /><span class="mailpoet_form_loading"><span class="mailpoet_bounce1"></span><span class="mailpoet_bounce2"></span><span class="mailpoet_bounce3"></span></span></div>
<div class="mailpoet_paragraph " >Your privacy is very important. WHAV will not sell, rent or give your personal information to anyone. If you’re not already helping to pay for local news, please consider making an optional donation.<br />
<a href="https://whav.net/become-a-whav-member/" target="_blank" rel="noopener"><img src="https://whav.net/wp-content/uploads/2020/11/donation_button.png" /></a></div>

      <div class="mailpoet_message">
        <p class="mailpoet_validate_success"
                style="display:none;"
                >Check your inbox or spam folder now to confirm your subscription.
        </p>
        <p class="mailpoet_validate_error"
                style="display:none;"
                >        </p>
      </div>
    </form>
  </div>

      </aside>
  	</div>
	</aside>

	</div> <!-- #main -->

</div><!-- #page -->


<div class="footer-bg clearfix nocontent">
	<footer id="site-footer">

		
<div id="supplementary" class="row-fluid _3col-equal">
	<div class="span4 widget-area" role="complementary">
	<aside id="text-45" class="widget widget-1 odd default widget_text clearfix"><h3 class="widgettitle">Professional Associations</h3>			<div class="textwidget"><style>
.ads-230 {
  text-align: center;
  background: ;
  height: 87px;
  line-height: 87px;
  max-width: 230px;
  width: 100%;
  display: block;
  margin:0 auto;
  }

  .ads-230 a {
  color: #666;
  }
  </style>

  <div class=>
    <a href="http://www.massbroadcasters.org/members/whav-lp" target="_blank" rel="noopener"><img src="https://whav.net/wp-content/uploads/mba_logo_230x87.png"></a>
  </div></div>
		</aside><aside id="text-128" class="widget widget-2 even widget_text clearfix">			<div class="textwidget"><style>
.ads-230 {<br />  text-align: center;<br />  background: ;<br />  height: 87px;<br />  line-height: 87px;<br />  max-width: 230px;<br />  width: 100%;<br />  display: block;<br />  margin:0 auto;<br />  }</p>
<p>  .ads-230 a {<br />  color: #666;<br />  }<br />  </style>
<div class=""><a href="https://rtdna.org/" target="_blank" rel="noopener"><img src="https://whav.net/wp-content/uploads/2018/09/rtdna_logo-230.png" /></a></div>
</div>
		</aside><aside id="text-74" class="widget widget-3 odd widget_text clearfix">			<div class="textwidget"><style>
.ads-230 {
  text-align: center;
  background: ;
  height: 87px;
  line-height: 87px;
  max-width: 230px;
  width: 100%;
  display: block;
  margin:0 auto;
  }

  .ads-230 a {
  color: #666;
  }
  </style>

  <div class=>
    <a href="http://nfcb.org/" target="_blank" rel="noopener"><img src="https://whav.net/wp-content/uploads/2016/08/NFCB_logo.jpg"></a>
  </div></div>
		</aside></div>

<div class="span4 widget-area" role="complementary">
	<aside id="text-147" class="widget widget-1 odd default widget_text clearfix"><h3 class="widgettitle">Network Affiliations</h3>			<div class="textwidget"><style>
.ads-230 {<br />
  text-align: center;<br />
  background: ;<br />
  height: 87px;<br />
  line-height: 87px;<br />
  max-width: 230px;<br />
  width: 100%;<br />
  display: block;<br />
  margin:0 auto;<br />
  }</p>
<p>  .ads-230 a {<br />
  color: #666;<br />
  }<br />
  </style>
<div class=""><a href="https://whav.net/category/state-house-news/" target="_blank" rel="noopener"><img src="https://whav.net/wp-content/uploads/2018/12/SHNS_logo-230.png" /></a></div>
</div>
		</aside><aside id="text-75" class="widget widget-2 even widget_text clearfix">			<div class="textwidget"><style>
.ads-230 {
  text-align: center;
  background: ;
  height: 87px;
  line-height: 87px;
  max-width: 230px;
  width: 100%;
  display: block;
  margin:0 auto;
  }

  .ads-230 a {
  color: #666;
  }
  </style>

  <div class=>
    <a href="https://twitter.com/featurestory" target="_blank" rel="noopener"><img src="https://whav.net/wp-content/uploads/2017/08/FSN_Logo.jpg"></a>
  </div></div>
		</aside></div>

<div class="span4 widget-area" role="complementary">
	<aside id="text-109" class="widget widget-1 odd default widget_text clearfix"><h3 class="widgettitle">WHAV News Hotline</h3>			<div class="textwidget"><style>
.ads-230x165 {<br />  text-align: center;<br />  background: ;<br />  height: 165px;<br />  line-height: 165px;<br />  max-width: 230px;<br />  width: 100%;<br />  display: block;<br />  margin:0 auto;<br />  }</p>
<p>  .ads-230x165 a {<br />  color: #666;<br />  }<br />  </style>
<div class="ads-230x165"><a href="https://whav.net/submit-news-tip/" target="_blank" rel="noopener"><img src="https://whav.net/wp-content/uploads/2017/09/WHAV_Red_Phone.jpg" /></a></div>
<div></div>
</div>
		</aside><aside id="text-184" class="widget widget-2 even default widget_text clearfix"><h3 class="widgettitle">Seal of Transparency</h3>			<div class="textwidget"><style>
.ads-230x165 {<br />  text-align: center;<br />  background: ;<br />  height: 165px;<br />  line-height: 165px;<br />  max-width: 230px;<br />  width: 100%;<br />  display: block;<br />  margin:0 auto;<br />  }</p>
<p>  .ads-230x165 a {<br />  color: #666;<br />  }<br />  </style>
<div class="ads-230x165"><a href="https://www.guidestar.org/profile/45-1702581" target="_blank" rel="noopener"><img src="https://whav.net/wp-content/uploads/2021/04/guidestar-silver-seal-2021-rgb.png" /></a></div>
<div></div>
</div>
		</aside></div>
</div>
<div id="boilerplate">
	<div class="row-fluid clearfix">
		<div class="span6">
			<ul id="footer-social" class="social-icons">
				<li><a href="https://www.facebook.com/pages/WHAV/56895487142" title="Link to Facebook Profile"><i class="icon-facebook"></i></a></li><li><a href="https://twitter.com/whavradio" title="Link to Twitter Page"><i class="icon-twitter"></i></a></li><li><a href="https://www.youtube.com/channel/UCBFlOKPkIoviQc1X9p91_6Q" title="Link to YouTube Page"><i class="icon-youtube"></i></a></li><li><a href="https://www.instagram.com/whavradio/" title="Link to Instagram Page"><i class="icon-instagram"></i></a></li><li><a href="https://whavradio.tumblr.com/" title="Link to Tumblr"><i class="icon-tumblr"></i></a></li><li><a href="https://www.linkedin.com/company/whav" title="Link to LinkedIn Page"><i class="icon-linkedin"></i></a></li><li><a href="https://whav.net/feed/" title="Link to RSS Feed"><i class="icon-rss"></i></a></li>			</ul>
			<div class="footer-bottom clearfix">

				<!-- If you enjoy this theme and use it on a production site we would appreciate it if you would leave the credit in place. Thanks :) -->
				<p class="footer-credit">&copy; Copyright 2021, Public Media of New England, Inc. WHAV® is a registered trademark.</p>
											</div>
		</div>

		<div class="span6 right">
			<p class="footer-credit">Built with the <a href="http://largoproject.org">Largo WordPress Theme</a> from the <a href="http://inn.org">Institute for Nonprofit News</a>.</p>
		</div>
	</div>

	<p class="back-to-top visuallyhidden"><a href="#top">Back to top &uarr;</a></p>
</div>

	</footer>
</div>




<script type="text/javascript" >
				if( document.querySelectorAll('[name^=ct_checkjs]').length > 0 ) {
					window.addEventListener('DOMContentLoaded', function () {
		                apbct_public_sendAJAX(
		                    { action: 'apbct_js_keys__get' },
		                    { callback: apbct_js_keys__set_input_value, no_nonce: true }
		                );
					});
				}
			</script>	  	<div id="fb-root"></div>
	  	<script><!--
			(function(d, s, id) {
			  var js, fjs = d.getElementsByTagName(s)[0];
			  if (d.getElementById(id)) return;
			  js = d.createElement(s); js.id = id;
			  js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.10&appId=71134849954';
			  fjs.parentNode.insertBefore(js, fjs);
			}(document, 'script', 'facebook-jssdk'));//-->
	  	</script>
	  	<div class="ws-plugin--s2member-s-badge">
	<a href="https://www.s2member.com/" onclick="window.open('http://www.s2member.com/s-badges/s-details.php?v=1&amp;site_url=https%3A%2F%2Fwhav.net', '_popup', 'width=770,height=720,left='+((screen.width/2)-(770/2))+',screenX='+((screen.width/2)-(770/2))+',top='+((screen.height/2)-(720/2))+',screenY='+((screen.height/2)-(720/2))+',location=0,menubar=0,toolbar=0,scrollbars=0,resizable=1'); return false;" title="s2Member&reg;"><img src="//www.s2member.com/s-badges/s-badge.php?v=1&amp;site_url=https%3A%2F%2Fwhav.net" width="200" height="55" style="border:0; width:200px; height:55px;" alt="s2Member&reg;" title="s2Member&reg; (Security for WordPress&reg;)" /></a>
</div><script type='text/javascript'>window._taboola = window._taboola || [];
_taboola.push({flush: true});</script>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/whav.net\/2021\/05\/03\/haverhill-marina-president-reports-trailer-broke-loose-causing-employees-facial-injury\/":365184};
	</script>
						<link rel='stylesheet' id='mailpoet_public-css'  href='https://whav.net/wp-content/plugins/mailpoet/assets/dist/css/mailpoet-public.dd713c66.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='mailpoet_custom_fonts_css-css'  href='https://fonts.googleapis.com/css?family=Abril+FatFace%3A400%2C400i%2C700%2C700i%7CAlegreya%3A400%2C400i%2C700%2C700i%7CAlegreya+Sans%3A400%2C400i%2C700%2C700i%7CAmatic+SC%3A400%2C400i%2C700%2C700i%7CAnonymous+Pro%3A400%2C400i%2C700%2C700i%7CArchitects+Daughter%3A400%2C400i%2C700%2C700i%7CArchivo%3A400%2C400i%2C700%2C700i%7CArchivo+Narrow%3A400%2C400i%2C700%2C700i%7CAsap%3A400%2C400i%2C700%2C700i%7CBarlow%3A400%2C400i%2C700%2C700i%7CBioRhyme%3A400%2C400i%2C700%2C700i%7CBonbon%3A400%2C400i%2C700%2C700i%7CCabin%3A400%2C400i%2C700%2C700i%7CCairo%3A400%2C400i%2C700%2C700i%7CCardo%3A400%2C400i%2C700%2C700i%7CChivo%3A400%2C400i%2C700%2C700i%7CConcert+One%3A400%2C400i%2C700%2C700i%7CCormorant%3A400%2C400i%2C700%2C700i%7CCrimson+Text%3A400%2C400i%2C700%2C700i%7CEczar%3A400%2C400i%2C700%2C700i%7CExo+2%3A400%2C400i%2C700%2C700i%7CFira+Sans%3A400%2C400i%2C700%2C700i%7CFjalla+One%3A400%2C400i%2C700%2C700i%7CFrank+Ruhl+Libre%3A400%2C400i%2C700%2C700i%7CGreat+Vibes%3A400%2C400i%2C700%2C700i%7CHeebo%3A400%2C400i%2C700%2C700i%7CIBM+Plex%3A400%2C400i%2C700%2C700i%7CInconsolata%3A400%2C400i%2C700%2C700i%7CIndie+Flower%3A400%2C400i%2C700%2C700i%7CInknut+Antiqua%3A400%2C400i%2C700%2C700i%7CInter%3A400%2C400i%2C700%2C700i%7CKarla%3A400%2C400i%2C700%2C700i%7CLibre+Baskerville%3A400%2C400i%2C700%2C700i%7CLibre+Franklin%3A400%2C400i%2C700%2C700i%7CMontserrat%3A400%2C400i%2C700%2C700i%7CNeuton%3A400%2C400i%2C700%2C700i%7CNotable%3A400%2C400i%2C700%2C700i%7CNothing+You+Could+Do%3A400%2C400i%2C700%2C700i%7CNoto+Sans%3A400%2C400i%2C700%2C700i%7CNunito%3A400%2C400i%2C700%2C700i%7COld+Standard+TT%3A400%2C400i%2C700%2C700i%7COxygen%3A400%2C400i%2C700%2C700i%7CPacifico%3A400%2C400i%2C700%2C700i%7CPoppins%3A400%2C400i%2C700%2C700i%7CProza+Libre%3A400%2C400i%2C700%2C700i%7CPT+Sans%3A400%2C400i%2C700%2C700i%7CPT+Serif%3A400%2C400i%2C700%2C700i%7CRakkas%3A400%2C400i%2C700%2C700i%7CReenie+Beanie%3A400%2C400i%2C700%2C700i%7CRoboto+Slab%3A400%2C400i%2C700%2C700i%7CRopa+Sans%3A400%2C400i%2C700%2C700i%7CRubik%3A400%2C400i%2C700%2C700i%7CShadows+Into+Light%3A400%2C400i%2C700%2C700i%7CSpace+Mono%3A400%2C400i%2C700%2C700i%7CSpectral%3A400%2C400i%2C700%2C700i%7CSue+Ellen+Francisco%3A400%2C400i%2C700%2C700i%7CTitillium+Web%3A400%2C400i%2C700%2C700i%7CUbuntu%3A400%2C400i%2C700%2C700i%7CVarela%3A400%2C400i%2C700%2C700i%7CVollkorn%3A400%2C400i%2C700%2C700i%7CWork+Sans%3A400%2C400i%2C700%2C700i%7CYatra+One%3A400%2C400i%2C700%2C700i&#038;ver=5.7.1' type='text/css' media='all' />
<script type='text/javascript' src='https://whav.net/wp-includes/js/comment-reply.min.js?ver=5.7.1' id='comment-reply-js'></script>
<script type='text/javascript' src='https://js.stripe.com/v3/' id='sandhills-stripe-js-v3-js'></script>
<script type='text/javascript' src='https://whav.net/wp-content/plugins/wp-simple-pay-pro-3/includes/core/assets/js/simpay-polyfill.min.js?ver=4.0.0-beta-2' id='simpay-polyfill-js'></script>
<script type='text/javascript' src='https://whav.net/wp-content/plugins/wp-simple-pay-pro-3/includes/core/assets/js/vendor/accounting.min.js?ver=4.0.0-beta-2' id='simpay-accounting-js'></script>
<script type='text/javascript' id='simpay-shared-js-extra'>
/* <![CDATA[ */
var spGeneral = {"strings":{"currency":"USD","currencySymbol":"$","currencyPosition":"left","decimalSeparator":".","thousandSeparator":",","ajaxurl":"https:\/\/whav.net\/wp-admin\/admin-ajax.php"},"booleans":{"isTestMode":false,"isZeroDecimal":false,"scriptDebug":false},"i18n":{"mediaTitle":"Insert Media","mediaButtonText":"Use Image","couponPercentOffText":"% off","couponAmountOffText":"off"},"integers":{"decimalPlaces":2,"minAmount":1}};
/* ]]> */
</script>
<script type='text/javascript' src='https://whav.net/wp-content/plugins/wp-simple-pay-pro-3/includes/core/assets/js/simpay-public-shared.min.js?ver=4.0.0-beta-2' id='simpay-shared-js'></script>
<script type='text/javascript' src='https://whav.net/wp-includes/js/underscore.min.js?ver=1.8.3' id='underscore-js'></script>
<script type='text/javascript' src='https://whav.net/wp-includes/js/backbone.min.js?ver=1.4.0' id='backbone-js'></script>
<script type='text/javascript' id='wp-api-request-js-extra'>
/* <![CDATA[ */
var wpApiSettings = {"root":"https:\/\/whav.net\/wp-json\/","nonce":"81a05927f5","versionString":"wp\/v2\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://whav.net/wp-includes/js/api-request.min.js?ver=5.7.1' id='wp-api-request-js'></script>
<script type='text/javascript' src='https://whav.net/wp-includes/js/wp-api.min.js?ver=5.7.1' id='wp-api-js'></script>
<script type='text/javascript' id='simpay-public-js-extra'>
/* <![CDATA[ */
var simplePayForms = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://whav.net/wp-content/plugins/wp-simple-pay-pro-3/includes/core/assets/js/simpay-public.min.js?ver=4.0.0-beta-2' id='simpay-public-js'></script>
<script type='text/javascript' src='https://whav.net/wp-content/plugins/wp-simple-pay-pro-3/includes/pro/assets/js/simpay-public-pro.min.js?ver=4.0.0-beta-2' id='simpay-public-pro-js'></script>
<script type='text/javascript' id='largoCore-js-extra'>
/* <![CDATA[ */
var Largo = {"is_home":"","is_single":"1","sticky_nav_options":{"sticky_nav_display":true,"main_nav_hide_article":false,"nav_overflow_label":"More"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://whav.net/wp-content/themes/largo-master/js/largoCore.min.js?ver=0.5.5.3' id='largoCore-js'></script>
<script type='text/javascript' src='https://whav.net/wp-content/themes/largo-master/js/navigation.min.js?ver=0.5.5.3' id='largo-navigation-js'></script>
<script type='text/javascript' src='https://whav.net/wp-content/themes/largo-master/js/largoPlugins.js?ver=0.5.5.3' id='largoPlugins-js'></script>
<script type='text/javascript' src='https://whav.net/wp-content/themes/largo-master/lib/navis-slideshows/vendor/slick/slick.min.js?ver=3.0' id='jquery-slick-js'></script>
<script type='text/javascript' src='https://whav.net/wp-content/themes/largo-master/lib/navis-slideshows/js/navis-slideshows.js?ver=0.11' id='navis-slideshows-js'></script>
<script type='text/javascript' data-cfasync="false" src='https://whav.net/wp-content/plugins/s2member/s2member-o.php?ws_plugin__s2member_js_w_globals=1&#038;qcABC=1&#038;ver=191022-191022-418948772' id='ws-plugin--s2member-js'></script>
<script type='text/javascript' src='https://whav.net/wp-includes/js/wp-embed.min.js?ver=5.7.1' id='wp-embed-js'></script>
<script type='text/javascript' src='https://whav.net/wp-content/plugins/jetpack/_inc/build/postmessage.min.js?ver=8.6.1' id='postmessage-js'></script>
<script type='text/javascript' src='https://whav.net/wp-content/plugins/jetpack/_inc/build/jquery.jetpack-resize.min.js?ver=8.6.1' id='jetpack_resize-js'></script>
<script type='text/javascript' src='https://whav.net/wp-content/plugins/jetpack/_inc/build/likes/queuehandler.min.js?ver=8.6.1' id='jetpack_likes_queuehandler-js'></script>
<script type='text/javascript' id='mailpoet_public-js-extra'>
/* <![CDATA[ */
var MailPoetForm = {"ajax_url":"https:\/\/whav.net\/wp-admin\/admin-ajax.php","is_rtl":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://whav.net/wp-content/plugins/mailpoet/assets/dist/js/public.1b92300b.js?ver=3.56.0' id='mailpoet_public-js'></script>
<script type='text/javascript' id='mailpoet_public-js-after'>
function initMailpoetTranslation() {
  if (typeof MailPoet !== 'undefined') {
    MailPoet.I18n.add('ajaxFailedErrorMessage', 'An error has happened while performing a request, please try again later.')
  } else {
    setTimeout(initMailpoetTranslation, 250);
  }
}
setTimeout(initMailpoetTranslation, 250);
</script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?onload=reCaptchaCallback&#038;render=explicit&#038;ver=5.7.1' id='mailpoet_recaptcha-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://whav.net/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=8.6.1' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-skype', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomskype', 'menubar=1,resizable=1,width=305,height=665' );
				return false;
			});
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=202118#ver=202118' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	<script type='text/javascript' src='https://stats.wp.com/e-202118.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.6.1',blog:'73071164',post:'365184',tz:'-4',srv:'whav.net'} ]);
	_stq.push([ 'clickTrackerInit', '73071164', '365184' ]);
</script>

</body>
</html>
